Network Issue

Incident Report for Owens ITS Status

Update

Everything is back up and running. We will continue to monitor for the next few days.
Posted Jan 01, 2026 - 14:02 EST

Update

We are slowly bringing our services back online.
Posted Jan 01, 2026 - 12:34 EST

Update

Power was restored but the issues that this presented are much more involved. We are working to restore services. Unknown at this time when we will be able to restore services.
Posted Dec 31, 2025 - 20:32 EST

Update

The power issue is being worked on and we have shutdown to avoid any more critical issues. Unknown at this time when we will be able to restore services.
Posted Dec 31, 2025 - 12:31 EST

Update

We are still experiencing issues. The phone system being one if them.
Posted Dec 31, 2025 - 07:07 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 30, 2025 - 23:19 EST

Investigating

We are currently experiencing a network issue. We are investigating.
Posted Dec 30, 2025 - 21:22 EST
This incident affects: Campus Physical Network, Campus WIFI, and Phone System.