Network and Phone Outage

Incident Report for Owens ITS Status

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 13:54 EDT

Investigating

We are experiencing a network and phone outage that we are investigating.
Posted Oct 01, 2025 - 09:07 EDT
This incident affected: Campus Physical Network, Campus WIFI, and Phone System.