Phone System Issue

Incident Report for Owens ITS Status

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 11:08 EDT

Identified

We have identified the problem and are working towards a solution.
Posted Sep 26, 2025 - 10:15 EDT

Update

We are continuing to investigate this issue.
Posted Sep 26, 2025 - 09:21 EDT

Investigating

We are currently experiencing issues with our Help Desk and Student Services phone groups. We are investigating the issue. All direct phone numbers are still working.
Posted Sep 26, 2025 - 09:20 EDT
This incident affected: Phone System.