PaperCut Outages
Incident Report for
Owens ITS Status
Identified
We have identified the problem and are working towards a solution. Academic Papercut printing is unavailable while we work to resolve this issue.
Posted
Sep
02
,
2026
-
16:24
EDT
Investigating
We are currently investigating issues with our PaperCut service.
Posted
Sep
02
,
2026
-
15:07
EDT
×
Subscribe to Incident
Subscribe to updates for
PaperCut Outages
via . You'll receive .