Inbound Calling Failure
Incident Report for Owens ITS Status
Resolved
We have resolved the issue.
Posted Jun 28, 2022 - 12:21 EDT
Identified
We are currently experiencing failures on our inbound calls. We are working with support to rectify the situation.
Posted Jun 28, 2022 - 10:48 EDT
This incident affected: Phone System.